Wednesday 25 July 2018

Solaris 11: Change host name using svccfg


When Solaris 11 was released more configurations were moved into the service management framework, and moved out of configuration files, one of these changes was the hostname/nodename.

View Hostname in SMF

This will read back the configuration out of the SMF.
 
# svccfg -s system/identity:node listprop config
config           application
config/nodename astring     solaris11box
config/loopback astring     solaris11box
 
Change Hostname in SMF

We have two separate settings, which need to be updated.
 
# svccfg -s system/identity:node setprop config/nodename = astring: newname
# svccfg -s system/identity:node setprop config/loopback = astring: newname
 
Review the Changes
 
# svccfg -s system/identity:node listprop config
config           application
config/nodename astring     newname
config/loopback astring     newname
 
Restart the Service to Reflect Changes

The system is now aware of the change, however it doesn’t use the change until the next reboot.  We can accelerate this by restarting the system/identity:node service.
 
# svccfg -s system/identity:node refresh
# svcadm restart system/identity:node
 
This will then show a system message reflecting the new hostname, to see the change in your shell prompt, you can spin off a child bash shell.  You can also use the hostname command to view the current hostname.

How to Delete or Clear old FMA/fmdump logs


What is Fault Management Architecture (FMA)

The Oracle Solaris OS includes an architecture for building and deploying systems and services
that are capable of predictive self healing. The service that is the core of the Fault Management
Architecture (FMA) receives data related to hardware and software errors and system changes,
and automatically diagnoses any underlying problem.

For a hardware fault, FMA attempts to take faulty components offline. For other hardware problems, software problems, and some
system changes, FMA provides information for the administrator to use to fix the problem.
Other system changes produce only informational notification

FMA can diagnose and manage faults, defects, and alerts:

Faults – A fault is a type of problem where something that used to work no longer does. A
fault typically describes a failed hardware component.
Defects – A defect is a type of problem where something never worked. A defect typically
describes a software component.
Alerts – An alert is neither a fault nor a defect. An alert can represent a problem or can be
simply informational.

■ The fmadm list command and the fmadm faulty commands display all active faults,
defects, and alerts.
■ The fmadm list-fault command displays all active faults.
■ The fmadm list-defect command displays all active defects.
■ The fmadm list-alert command displays all active alerts.

fmadm replaced

Use the fmadm replaced command to indicate that the suspect FRU has been replaced. If
multiple faults are currently reported against one FRU, the FRU shows as replaced in all cases.

fmadm replaced FMRI | label

When an FRU is replaced, the serial number of the FRU changes. If fmd automatically detects
that the serial number of an FRU has changed, the Fault Manager behaves in the same way
as if you had entered the fmadm replaced command. If fmd cannot detect whether the serial
number of the FRU has changed, then you must enter the fmadm replaced command if you
have replaced the FRU. If fmd detects that the serial number of the FRU has not changed, then
the fmadm replaced command exits with an error.
If you remove the FRU but do not replace the FRU, the Fault Manager displays the suspect as
not present.

fmadm repaired

Use the fmadm repaired command when you have performed a physical repair other than
replacement of the FRU to resolve the problem. Examples of such repairs include reseating a
card or straightening a bent pin. If multiple faults are currently reported against one FRU, the
FRU shows as repaired in all cases.

fmadm repaired FMRI | label

fmadm acquit

Use the acquit subcommand if you determine that the indicated resource is not the cause of the
fault. Usually the Fault Manager automatically acquits some suspects in a multi-element suspect
list.

Replacement takes precedence over repair, and both replacement and repair take precedence
over acquittal. Thus, you can acquit a component and then subsequently repair the component,
but you cannot acquit a component that has already been repaired.

If you do not specify any FMRI or label with the UUID, then the entire event is identified as
able to be ignored. A case is considered repaired when the fault event UUID is acquitted.

fmadm acquit UUID

Acquit by FMRI or label with no UUID only if you determine that the resource is not a factor
in any current cases in which that resource is a suspect. If multiple faults are currently reported
against one FRU, the FRU shows as acquitted in all cases.

fmadm acquit FMRI
fmadm acquit label


To acquit a resource in one case and keep that resource as a suspect in other cases, specify both
the fault event UUID and the resource FMRI or both the UUID and the resource label, as shown
in the following examples

fmadm acquit FMRI UUID
fmadm acquit label UUID
 

Disable service:

svcadm disable -s svc:/system/fmd:default

Clearing logs:

# go to directory with logs
cd /var/fm/fmd
# looking list of logs/files
find /var/fm/fmd -type f -exec ls {} \;
# clearing logs
find /var/fm/fmd -type f -exec rm {} \;

Enable fmd service:

svcadm enable svc:/system/fmd:default

Reset the fmd serd modules:


fmadm reset cpumem-diagnosis
fmadm reset cpumem-retire
fmadm reset eft
fmadm reset io-retire

Saturday 21 July 2018

Solaris 11 SRU Upgrade Using Local Repository

Solaris 11 SRU Upgrade Using Local Repository

1. Verify the Solaris OS version
bash-4.1# uname -a
SunOS Sol11-ldom 5.11 11.2 sun4v sparc sun4v
2. Verify the Solaris repository is accessable and has correct publisher is configured
bash-4.1# pkg publisher
PUBLISHER                   TYPE     STATUS P LOCATION
solaris                     origin   online F http://sol11-repo.domain.co.nz:81/
3. If Publisher is not configured or not listing the correct publisher run the below command
bash-4.1# pkg set-publisher -G '*' -g 'http://sol11-repo.domain.co.nz:81/' solaris
4. Verify that the repository has required SRUs available for upgate
bash-4.1# pkg list -af entire
NAME (PUBLISHER)                                  VERSION                    IFO
entire                                            0.5.11-0.175.2.15.0.4.0    ---
entire                                            0.5.11-0.175.2.6.0.4.0     i--
entire                                            0.5.11-0.175.2.0.0.42.0    ---
entire                                            0.5.11-0.175.1.19.0.6.0    ---
entire                                            0.5.11-0.175.1.0.0.24.2    ---
5. Ensure the rpool having enough space to accommodate a new BE
bash-4.1# zpool list
NAME        SIZE  ALLOC   FREE  CAP  DEDUP  HEALTH  ALTROOT
S10Zone  79.5G  16.2G  63.3G  20%  1.00x  ONLINE  -
rpool      47.8G  42.8G  5.00G  89%  1.00x  ONLINE  -       <<------
swap912    47.8G  32.0G  15.7G  67%  1.00x  ONLINE  -
6. Check whtether there is any quota is enabled root file system, if yes remove the quota or increase the quota
bash-4.1# zfs get refquota,quota rpool/ROOT/solaris-1
NAME                  PROPERTY  VALUE  SOURCE
rpool/ROOT/solaris-1  refquota  none   default
rpool/ROOT/solaris-1  quota     none   default
bash-4.1# zfs get refquota,quota rpool/ROOT/solaris-2/var
NAME                      PROPERTY  VALUE  SOURCE
rpool/ROOT/solaris-2/var  refquota  none   default
rpool/ROOT/solaris-2/var  quota     none   default
7. List the BE's and remove the old BE if you are running out of space
bash-4.1# beadm list
BE               Active Mountpoint Space  Policy Created
--               ------ ---------- -----  ------ -------
install          -      -          62.0K  static 2015-04-09 10:23
pre_11_2         -      -          3.43M  static 2015-04-09 11:42
pre_vxvm610      -      -          258.0K static 2015-04-09 10:35
solaris          -      -          24.05M static 2015-04-09 09:54
solaris-1        NR     /          16.73G static 2015-04-09 11:54 <<--Current BE
solaris-backup-1 -      -          3.47M  static 2015-04-09 11:27
8. Check the snapshots and remove old snapshots if you need more space
bash-4.1# zfs list -t snapshot -r rool/ROOT
NAME                                           USED  AVAIL  REFER  MOUNTPOINT
rpool@backup0                                   19K      -  73.5K  -
rpool@backup1                                     0      -  73.5K  -
rpool/ROOT@backup0                                0      -    31K  -
rpool/ROOT@backup1                                0      -    31K  -
rpool/ROOT/solaris-1@install                  1.67M      -  1.90G  -
rpool/ROOT/solaris-1@2015-04-08-22:23:37      22.4M      -  1.97G  -
rpool/ROOT/solaris-1@2015-04-08-22:35:10      22.9M      -  2.27G  -
rpool/ROOT/solaris-1@2015-04-08-23:27:36       247K      -  2.91G  -
rpool/ROOT/solaris-1@2015-04-08-23:42:02          0      -  2.91G  -
rpool/ROOT/solaris-1@2015-04-08-23:54:41          0      -  2.91G  -
rpool/ROOT/solaris-1@backup0                   135M      -  3.75G  -
rpool/ROOT/solaris-1@backup1                  78.0M      -  3.75G  -
rpool/ROOT/solaris-1/var@install              1.67M      -   163M  -
rpool/ROOT/solaris-1/var@2015-04-08-22:23:37   192K      -   163M  -
rpool/ROOT/solaris-1/var@2015-04-08-22:35:10   101M      -   179M  -
rpool/ROOT/solaris-1/var@2015-04-08-23:27:36  29.0M      -  1.82G  -
rpool/ROOT/solaris-1/var@2015-04-08-23:42:02   457K      -  1.89G  -
rpool/ROOT/solaris-1/var@2015-04-08-23:54:41   709M      -  2.64G  -
rpool/ROOT/solaris-1/var@backup0               203M      -  2.02G  -
rpool/ROOT/solaris-1/var@backup1              45.0M      -  2.08G  -

9. Run the pkg update dry-run and verify the outcome. It will report you if there will be any failure
bash-4.1# pkg update -nv                    <<--- (-n means dry-run)
           Packages to remove:       2
          Packages to install:      36
           Packages to update:     264
           Packages to change:       1
          Mediators to change:       1
    Estimated space available: 3.25 GB   <<----
Estimated space to be consumed: 2.59 GB
      Create boot environment:     Yes
    Activate boot environment:     Yes
Create backup boot environment:      No
         Rebuild boot archive:     Yes
Changed mediators:
 mediator java:
          version: 1.7 (system default) -> 1.8 (system default)
Changed packages:
solaris
 service/storage/media-volume-manager
   0.5.11,5.11-0.173.0.0.0.1.0:20110826T161917Z -> None
 system/extended-system-utilities
   0.5.11,5.11-0.170:20110719T015321Z -> None
 compress/pigz
   None -> 2.2.5,5.11-0.175.2.4.0.5.0:20141030T213653Z
 consolidation/ddt/ddt-incorporation
   None -> 8.9.15.9.11,5.11:20150916T171410Z
 developer/library/xprofile
   None -> 0.5.11,5.11-0.175.2.0.0.34.0:20140303T132011Z
 driver/network/ethernet/i40e
   None -> 0.5.11,5.11-0.175.2.12.0.4.2:20150626T204643Z
 image/scanner/xsane/sane-backends
   None -> 1.0.19,5.11-0.175.2.0.0.42.1:20140623T013746Z
 library/python-2/argparse
   None -> 1.2.1,5.11-0.175.2.0.0.42.1:20140623T014619Z
 library/python-2/argparse-26
   None -> 1.2.1,5.11-0.175.2.0.0.42.1:20140623T014618Z
 library/python-2/cherrypy-27
   None -> 3.1.2,5.11-0.175.2.0.0.42.1:20140623T014648Z
 library/python-2/jsonrpclib-27
   None -> 0.1.3,5.11-0.175.2.0.0.42.1:20140623T014824Z
 library/python-2/libxsl-27
   None -> 1.1.28,5.11-0.175.2.0.0.42.1:20140623T014853Z
 library/python-2/lxml-27
   None -> 2.3.3,5.11-0.175.2.10.0.4.0:20150423T235139Z
 library/python-2/m2crypto-27
   None -> 0.21.1,5.11-0.175.2.0.0.42.1:20140623T014921Z
 library/python-2/mako-27
   None -> 0.4.1,5.11-0.175.2.0.0.42.1:20140623T014927Z
 library/python-2/net-snmp-27
   None -> 5.4.1,5.11-0.175.2.13.0.4.0:20150724T230046Z
 library/python-2/pip
   None -> 6.0.8,5.11-0.175.2.12.0.3.0:20150622T165250Z
 library/python-2/pip-26
   None -> 6.0.8,5.11-0.175.2.12.0.3.0:20150622T165246Z
 library/python-2/pip-27
   None -> 6.0.8,5.11-0.175.2.12.0.3.0:20150622T165248Z
 library/python-2/ply-27
   None -> 3.1,5.11-0.175.2.0.0.42.1:20140623T015025Z
 library/python-2/pybonjour-27
   None -> 1.1.1,5.11-0.175.2.0.0.42.1:20140623T015043Z
 library/python-2/pycurl-27
   None -> 7.19.0.1,5.11-0.175.2.0.0.42.1:20140623T015059Z
 library/python-2/pyopenssl-27
   None -> 0.13,5.11-0.175.2.10.0.4.0:20150423T235203Z
 library/python-2/requests
   None -> 2.6.0,5.11-0.175.2.10.0.4.0:20150423T235222Z
 library/python-2/requests-26
   None -> 2.6.0,5.11-0.175.2.10.0.4.0:20150423T235216Z
 library/python-2/requests-27
   None -> 2.6.0,5.11-0.175.2.10.0.4.0:20150423T235219Z
 library/python-2/setuptools
   None -> 0.6.11,5.11-0.175.2.0.0.42.1:20140623T015258Z
 library/python-2/setuptools-26
   None -> 0.6.11,5.11-0.175.2.0.0.42.1:20140623T015252Z
 library/python-2/setuptools-27
   None -> 0.6.11,5.11-0.175.2.0.0.42.1:20140623T015254Z
 library/python-2/simplejson-27
   None -> 3.6.5,5.11-0.175.2.10.0.4.0:20150423T235224Z
 library/python-2/tkinter-26
   None -> 2.6.8,5.11-0.175.2.8.0.3.0:20150221T004153Z
 library/python/libxml2-27
   None -> 2.9.2,5.11-0.175.2.6.0.3.0:20141222T165009Z
 library/python/tkinter-27
   None -> 2.7.9,5.11-0.175.2.10.0.4.0:20150423T235042Z
 runtime/java/jre-8
   None -> 1.8.0.60.27,5.11:20150812T161247Z
 runtime/python-27
   None -> 2.7.9,5.11-0.175.2.10.0.4.0:20150423T235326Z
 runtime/python-27/tests
   None -> 2.7.9,5.11-0.175.2.10.0.4.0:20150423T235311Z
 runtime/tk-8
   None -> 8.5.12,5.11-0.175.2.0.0.42.1:20140623T021316Z
 system/storage/nvme-utilities
   None -> 0.5.11,5.11-0.175.2.14.0.2.0:20150813T225458Z
 compress/gzip
   1.5,5.11-0.175.2.4.0.3.0:20141022T002431Z -> 1.5,5.11-0.175.2.10.0.1.0:20150406T225713Z
 compress/p7zip
   9.20.1,5.11-0.175.2.5.0.3.0:20141124T151553Z -> 9.20.1,5.11-0.175.2.13.0.2.0:20150710T213708Z
 compress/unzip
   6.0,5.11-0.175.2.3.0.4.0:20141002T141542Z -> 6.0,5.11-0.175.2.10.0.4.0:20150423T234753Z
 consolidation/SunVTS/SunVTS-incorporation
   7.18.2,5.11-0.175.2.1.0.5.1:20140801T185126Z -> 7.19.2,5.11-0.175.2.9.0.3.1:20150321T015045Z
 consolidation/X/X-incorporation
   0.5.11,5.11-0.175.2.6.0.3.1423:20141222T165127Z -> 0.5.11,5.11-0.175.2.11.0.2.1436:20150515T221810Z
 consolidation/cns/cns-incorporation
   0.5.11,5.11-0.175.2.0.0.39.0:20140512T125220Z -> 0.5.11,5.11-0.175.2.12.0.2.0:20150615T141349Z
 consolidation/desktop/desktop-incorporation
   0.5.11,5.11-0.175.2.5.0.4.0:20141201T211353Z -> 0.5.11,5.11-0.175.2.13.0.3.0:20150720T153012Z
 consolidation/desktop/gnome-incorporation
   0.5.11,5.11-0.175.2.0.0.42.0:20140623T125514Z -> 0.5.11,5.11-0.175.2.13.0.3.0:20150720T153013Z
 consolidation/ips/ips-incorporation
   0.5.11,5.11-0.175.2.6.0.2.0:20141212T230005Z -> 0.5.11,5.11-0.175.2.13.0.5.0:20150731T191350Z
 consolidation/java-7/java-7-incorporation
   1.7.0.72.14,5.11-0:20141009T234935Z -> 1.7.0.85.33,5.11-0:20150805T160431Z
 consolidation/java-8/java-8-incorporation
   1.8.0.25.17,5.11-0:20141009T235310Z -> 1.8.0.60.27,5.11-0:20150812T161222Z
 consolidation/l10n/l10n-incorporation
   0.5.11,5.11-0.175.2.1.0.4.2:20140728T200523Z -> 0.5.11,5.11-0.175.2.12.0.3.2:20150622T162532Z
 consolidation/ldoms/ldoms-incorporation
   0.5.11,5.11-0.175.2.5.0.2.0:20141114T212701Z -> 0.5.11,5.11-0.175.2.11.0.3.0:20150526T144347Z
 consolidation/osnet/osnet-incorporation
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T163916Z -> 0.5.11,5.11-0.175.2.15.0.4.2:20150923T160304Z
 consolidation/solaris_re/solaris_re-incorporation
   0.5.11,5.11-0.175.2.4.0.4.0:20141027T160116Z -> 0.5.11,5.11-0.175.2.12.0.3.0:20150622T164923Z
 consolidation/ssm/ssm-incorporation
   2.2.8,5.11-0.175.2.2.0.4.0:20140829T201639Z -> 2.3.3.0,5.11-0.175.2.14.0.2.0:20150813T225348Z
 consolidation/sunpro/sunpro-incorporation
   0.5.11,5.11-0.175.2.5.0.2.0:20141114T212720Z -> 0.5.11,5.11-0.175.2.13.0.2.0:20150710T212917Z
 consolidation/ub_javavm-6/ub_javavm-6-incorporation
   1.6.0.85,5.11-0:20141009T234726Z -> 1.6.0.101,5.11-0:20150701T162722Z
 consolidation/userland/userland-incorporation
   0.5.11,5.11-0.175.2.6.0.4.0:20150105T163414Z -> 0.5.11,5.11-0.175.2.15.0.4.0:20150923T160421Z
 crypto/ca-certificates
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T183908Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153154Z
 database/sqlite-3
   3.8.2,5.11-0.175.2.5.0.4.0:20141201T211407Z -> 3.8.8.1,5.11-0.175.2.9.0.4.0:20150330T211600Z
 developer/assembler
   0.5.11,5.11-0.175.2.5.0.2.0:20141114T212721Z -> 0.5.11,5.11-0.175.2.13.0.2.0:20150710T212918Z
 developer/base-developer-utilities
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T183921Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153156Z
 developer/debug/mdb
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224252Z -> 0.5.11,5.11-0.175.2.15.0.4.2:20150923T160306Z
 diagnostic/cpu-counters
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184011Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201753Z
 diagnostic/ddu/library
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184017Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025103Z
 diagnostic/ddu/text
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184019Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025109Z
 diagnostic/snoop
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T202135Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025118Z
 diagnostic/tcpdump
   4.5.1,5.11-0.175.2.0.0.42.1:20140623T013028Z -> 4.7.4,5.11-0.175.2.12.0.4.0:20150626T205014Z
 diagnostic/wireshark/tshark
   1.10.11,5.11-0.175.2.6.0.2.0:20141212T225139Z -> 1.10.14,5.11-0.175.2.11.0.3.0:20150526T145312Z
 diagnostic/wireshark/wireshark-common
   1.10.11,5.11-0.175.2.6.0.2.0:20141212T225140Z -> 1.10.14,5.11-0.175.2.11.0.3.0:20150526T145313Z
 driver/crypto/n2cp
   0.5.11,5.11-0.175.2.2.0.4.2:20140829T201028Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025121Z
 driver/crypto/tpm
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184045Z -> 0.5.11,5.11-0.175.2.11.0.3.2:20150526T144533Z
 driver/fc/emlxs
   0.5.11,5.11-0.175.2.1.0.5.2:20140801T183723Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153223Z
 driver/fc/qlc
   0.5.11,5.11-0.175.2.4.0.3.2:20141021T235418Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173038Z
 driver/fc/socal
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184104Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201800Z
 driver/graphics/mga
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184114Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025152Z
 driver/infiniband/connectx
   0.5.11,5.11-0.175.2.3.0.2.2:20140912T210345Z -> 0.5.11,5.11-0.175.2.13.0.1.2:20150706T181044Z
 driver/management/ipmi
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184124Z -> 0.5.11,5.11-0.175.2.9.0.3.2:20150321T013959Z
 driver/network/ethernet/bnxe
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184135Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201804Z
 driver/network/ethernet/cxge
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184145Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201812Z
 driver/network/ethernet/e1000g
   0.5.11,5.11-0.175.2.1.0.5.2:20140801T183735Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201814Z
 driver/network/ethernet/hxge
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184157Z -> 0.5.11,5.11-0.175.2.8.0.3.2:20150221T002507Z
 driver/network/ethernet/igb
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224327Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025211Z
 driver/network/ethernet/ixgbe
   0.5.11,5.11-0.175.2.5.0.3.2:20141124T150724Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173044Z
 driver/network/ethernet/nxge
   0.5.11,5.11-0.175.2.5.0.2.2:20141114T211825Z -> 0.5.11,5.11-0.175.2.13.0.1.2:20150706T181047Z
 driver/network/ethernet/qlcnic
   0.5.11,5.11-0.175.2.4.0.3.2:20141021T235432Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025218Z
 driver/network/ethernet/usbecm
   0.5.11,5.11-0.175.2.3.0.1.2:20140905T182935Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173047Z
 driver/network/wlan/pcan
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184255Z -> 0.5.11,5.11-0.175.2.8.0.2.2:20150214T030438Z
 driver/network/wlan/pcwl
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184257Z -> 0.5.11,5.11-0.175.2.8.0.2.2:20150214T030439Z
 driver/pcmcia
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184314Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201816Z
 driver/serial/usbsksp/usbs49_fw
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184325Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173048Z
 driver/storage/aac
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184329Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025226Z
 driver/storage/blkdev
   0.5.11,5.11-0.175.2.5.0.3.2:20141124T150727Z -> 0.5.11,5.11-0.175.2.12.0.2.2:20150615T141522Z
 driver/storage/glm
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184344Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201820Z
 driver/storage/isp
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184350Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201822Z
 driver/storage/lmrc
   0.5.11,5.11-0.175.2.5.0.4.2:20141201T211004Z -> 0.5.11,5.11-0.175.2.12.0.3.2:20150622T164430Z
 driver/storage/lsc
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T154841Z -> 0.5.11,5.11-0.175.2.9.0.4.2:20150330T212230Z
 driver/storage/mpt
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T154843Z -> 0.5.11,5.11-0.175.2.14.0.2.2:20150813T225236Z
 driver/storage/mpt_sas
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T163933Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153231Z
 driver/storage/mr_sas
   0.5.11,5.11-0.175.2.2.0.4.2:20140829T201029Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025253Z
 driver/storage/nvme
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224330Z -> 0.5.11,5.11-0.175.2.13.0.1.2:20150706T181051Z
 driver/storage/pmcs
   0.5.11,5.11-0.175.2.4.0.3.2:20141021T235438Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173049Z
 driver/storage/scsa1394
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184417Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T201833Z
 driver/storage/ses
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184422Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025309Z
 driver/storage/ssd
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184427Z -> 0.5.11,5.11-0.175.2.13.0.2.2:20150710T213032Z
 entire
   0.5.11,5.11-0.175.2.6.0.4.0:20150105T164242Z -> 0.5.11,5.11-0.175.2.15.0.4.0:20150923T161056Z
 group/system/solaris-core-platform
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184444Z -> 0.5.11,5.11-0.175.2.8.0.2.2:20150214T030453Z
 group/system/solaris-large-server
   0.5.11,5.11-0.175.2.4.0.4.0:20141027T160120Z -> 0.5.11,5.11-0.175.2.12.0.3.0:20150622T164928Z
 image/library/libpng
   1.4.11,5.11-0.175.2.0.0.39.0:20140512T130109Z -> 1.4.11,5.11-0.175.2.13.0.3.0:20150720T153014Z
 install/archive
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184445Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025316Z
 install/distribution-constructor
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184447Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T175943Z
 install/installadm
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184449Z -> 0.5.11,5.11-0.175.2.13.0.2.2:20150710T213034Z
 install/js2ai
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184452Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025340Z
 library/glib2
   2.28.6,5.11-0.175.2.0.0.33.0:20140217T134213Z -> 2.28.6,5.11-0.175.2.13.0.3.0:20150720T153018Z
 library/libmilter
   8.14.9,5.11-0.175.2.4.0.4.2:20141027T154845Z -> 8.15.1,5.11-0.175.2.12.0.1.2:20150605T173054Z
 library/openldap
   2.4.30,5.11-0.175.2.0.0.42.1:20140623T014203Z -> 2.4.30,5.11-0.175.2.14.0.2.0:20150813T225334Z
 library/pcre
   8.21,5.11-0.175.2.0.0.42.1:20140623T014214Z -> 8.37,5.11-0.175.2.13.0.3.0:20150720T154042Z
 library/perl-5/openscap-512
   1.0.0,5.11-0.175.2.4.0.3.0:20141022T002642Z -> 1.0.0,5.11-0.175.2.11.0.4.0:20150601T150957Z
 library/perl-5/sun-solaris-512
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184501Z -> 0.5.11,5.11-0.175.2.11.0.4.2:20150601T150441Z
 library/python-2/locale-services
   0.5.11,5.11-0.175.2.0.0.42.2:20140623T130350Z -> 0.5.11,5.11-0.175.2.8.0.1.3:20150207T032215Z
 library/python-2/lxml
   2.3.3,5.11-0.175.2.5.0.1.0:20141110T173605Z -> 2.3.3,5.11-0.175.2.10.0.4.0:20150423T235144Z
 library/python-2/lxml-26
   2.3.3,5.11-0.175.2.5.0.1.0:20141110T173553Z -> 2.3.3,5.11-0.175.2.10.0.4.0:20150423T235133Z
 library/python-2/net-snmp-26
   5.4.1,5.11-0.175.2.5.0.1.0:20141110T173606Z -> 5.4.1,5.11-0.175.2.13.0.4.0:20150724T230045Z
 library/python-2/openscap-26
   1.0.0,5.11-0.175.2.4.0.3.0:20141022T002703Z -> 1.0.0,5.11-0.175.2.11.0.4.0:20150601T150959Z
 library/python-2/pyopenssl
   0.13,5.11-0.175.2.0.0.42.1:20140623T015118Z -> 0.13,5.11-0.175.2.10.0.4.0:20150423T235205Z
 library/python-2/pyopenssl-26
   0.13,5.11-0.175.2.0.0.42.1:20140623T015114Z -> 0.13,5.11-0.175.2.10.0.4.0:20150423T235202Z
 library/python-2/simplejson
   2.1.2,5.11-0.175.2.0.0.42.1:20140623T015303Z -> 3.6.5,5.11-0.175.2.10.0.4.0:20150423T235225Z
 library/python-2/simplejson-26
   2.1.2,5.11-0.175.2.0.0.42.1:20140623T015259Z -> 3.6.5,5.11-0.175.2.10.0.4.0:20150423T235222Z
 library/security/openssl
   1.0.1.10,5.11-0.175.2.6.0.1.0:20141208T172514Z -> 1.0.1.16,5.11-0.175.2.13.0.3.0:20150720T154105Z
 library/security/openssl/openssl-fips-140
   2.0.6,5.11-0.175.2.6.0.1.0:20141208T172503Z -> 2.0.6,5.11-0.175.2.13.0.3.0:20150720T154055Z
 library/security/trousers
   0.3.6,5.11-0.175.2.0.0.42.1:20140623T015438Z -> 0.3.6,5.11-0.175.2.10.0.3.0:20150417T202805Z
 naming/ldap
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T202144Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025352Z
 network/dns/bind
   9.6.3.11.1,5.11-0.175.2.6.0.3.0:20141222T165026Z -> 9.6.3.11.3,5.11-0.175.2.15.0.2.0:20150911T010421Z
 network/finger
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184511Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025356Z
 network/ftp
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184512Z -> 0.5.11,5.11-0.175.2.13.0.2.2:20150710T213036Z
 network/ipfilter
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T154847Z -> 0.5.11,5.11-0.175.2.13.0.2.2:20150710T213038Z
 network/legacy-remote-utilities
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184521Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025418Z
 network/open-fabrics
   1.5.3,5.11-0.175.2.2.0.2.0:20140815T214850Z -> 1.5.3,5.11-0.175.2.8.0.3.0:20150221T004155Z
 network/ping
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184525Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025428Z
 network/ssh
   0.5.11,5.11-0.175.2.2.0.2.2:20140815T214232Z -> 0.5.11,5.11-0.175.2.8.0.3.2:20150221T002519Z
 network/ssh/ssh-key
   0.5.11,5.11-0.175.2.2.0.2.2:20140815T214229Z -> 0.5.11,5.11-0.175.2.8.0.3.2:20150221T002517Z
 network/telnet
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184534Z -> 0.5.11,5.11-0.175.2.13.0.2.2:20150710T213043Z
 network/whois
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184535Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025442Z
 package/pkg
   0.5.11,5.11-0.175.2.6.0.2.0:20141212T230006Z -> 0.5.11,5.11-0.175.2.13.0.5.0:20150731T191351Z
 package/pkg/system-repository
   0.5.11,5.11-0.175.2.3.0.3.0:20140922T212539Z -> 0.5.11,5.11-0.175.2.10.0.3.0:20150417T202816Z
 package/rpm
   0.5.11,5.11-0.175.2.0.0.42.1:20140623T015556Z -> 1.3,5.11-0.175.2.12.0.4.0:20150626T205031Z
 package/svr4
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184537Z -> 0.5.11,5.11-0.175.2.10.0.5.2:20150506T003420Z
 print/filter/hplip
   3.12.4,5.11-0.175.2.0.0.42.1:20140623T015825Z -> 3.14.6,5.11-0.175.2.9.0.3.0:20150321T015151Z
 release/name
   0.5.11,5.11-0.175.2.4.0.4.0:20141027T160123Z -> 0.5.11,5.11-0.175.2.12.0.3.0:20150622T164932Z
 release/notices
   0.5.11,5.11-0.175.2.4.0.4.0:20141027T160124Z -> 0.5.11,5.11-0.175.2.12.0.3.0:20150622T164933Z
 runtime/java
   1.6.0.85,5.11:20141009T234855Z -> 1.6.0.101,5.11:20150701T162849Z
 runtime/java/jre-6
   1.6.0.85,5.11:20141009T234753Z -> 1.6.0.101,5.11:20150701T162748Z
 runtime/java/jre-7
   1.7.0.72.14,5.11:20141009T235011Z -> 1.7.0.85.33,5.11:20150805T160501Z
 runtime/perl-512
   5.12.5,5.11-0.175.2.4.0.4.0:20141027T155940Z -> 5.12.5,5.11-0.175.2.9.0.3.0:20150321T015205Z
 runtime/python-26
   2.6.8,5.11-0.175.2.6.0.2.0:20141212T225408Z -> 2.6.8,5.11-0.175.2.10.0.4.0:20150423T235245Z
 security/compliance/benchmark/pci-dss
   0.5.11,5.11-0.175.2.5.0.1.2:20141110T172722Z -> 0.5.11,5.11-0.175.2.11.0.2.2:20150515T221104Z
 security/compliance/benchmark/solaris-policy
   0.5.11,5.11-0.175.2.5.0.1.2:20141110T172723Z -> 0.5.11,5.11-0.175.2.11.0.2.2:20150515T221105Z
 security/compliance/openscap
   1.0.0,5.11-0.175.2.4.0.3.0:20141022T004027Z -> 1.0.0,5.11-0.175.2.11.0.4.0:20150601T151002Z
 security/compliance/policy-tests
   0.5.11,5.11-0.175.2.5.0.1.2:20141110T172723Z -> 0.5.11,5.11-0.175.2.11.0.2.2:20150515T221106Z
 service/file-system/nfs
   0.5.11,5.11-0.175.2.5.0.4.2:20141201T211008Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173055Z
 service/file-system/smb
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184709Z -> 0.5.11,5.11-0.175.2.8.0.3.2:20150221T002528Z
 service/network/dns/bind
   9.6.3.11.1,5.11-0.175.2.6.0.3.0:20141222T165048Z -> 9.6.3.11.3,5.11-0.175.2.15.0.2.0:20150911T010424Z
 service/network/ftp
   1.3.5,5.11-0.175.2.5.0.1.0:20141110T173748Z -> 1.3.5,5.11-0.175.2.15.0.3.0:20150916T192207Z
 service/network/load-balancer/ilb
   0.5.11,5.11-0.175.2.5.0.1.2:20141110T172732Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025737Z
 service/network/ntp
   4.2.8,5.11-0.175.2.6.0.4.0:20150105T163416Z -> 4.2.8.2,5.11-0.175.2.10.0.5.0:20150506T003743Z
 service/network/smtp/sendmail
   8.14.9,5.11-0.175.2.5.0.3.2:20141124T150847Z -> 8.15.1,5.11-0.175.2.14.0.3.2:20150821T175944Z
 service/network/ssh
   0.5.11,5.11-0.175.2.3.0.1.2:20140905T182947Z -> 0.5.11,5.11-0.175.2.15.0.3.2:20150916T192018Z
 service/network/tftp
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184752Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025800Z
 service/network/wpa
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184758Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153235Z
 service/security/gss
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184759Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025801Z
 service/security/kerberos-5
   0.5.11,5.11-0.175.2.6.0.1.2:20141208T171912Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153236Z
 shell/bash
   4.1.17,5.11-0.175.2.5.0.2.0:20141114T212619Z -> 4.1.17,5.11-0.175.2.9.0.3.0:20150321T015321Z
 support/explorer
   8.6.14.12.5,5.11:20141209T180905Z -> 8.9.15.9.11,5.11:20150916T171411Z
 system/accounting/legacy-accounting
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184904Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T025915Z
 system/boot-environment-utilities
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184924Z -> 0.5.11,5.11-0.175.2.10.0.2.2:20150413T212642Z
 system/boot/grub
   1.99,5.11-0.175.2.2.0.3.2:20140826T020518Z -> 1.99,5.11-0.175.2.15.0.2.2:20150911T010410Z
 system/boot/wanboot
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T184922Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153253Z
 system/core-os
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T163942Z -> 0.5.11,5.11-0.175.2.14.0.2.2:20150813T225239Z
 system/data/hardware-registry
   0.5.11,5.11-0.175.2.0.0.42.1:20140623T021644Z -> 0.5.11,5.11-0.175.2.10.0.4.0:20150423T235352Z
 system/data/timezone
   0.5.11,5.11-0.175.2.5.0.2.0:20141114T212623Z -> 2015.5,5.11-5.11:20150626T205332Z
 system/device-administration
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T155111Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030254Z
 system/domain-configuration/sparc-enterprise
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185058Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030303Z
 system/dtrace
   0.5.11,5.11-0.175.2.4.0.3.2:20141022T000150Z -> 0.5.11,5.11-0.175.2.12.0.4.2:20150626T204751Z
 system/dtrace/dtrace-toolkit
   0.99,5.11-0.175.2.0.0.42.2:20140624T185101Z -> 0.99,5.11-0.175.2.11.0.2.2:20150515T221108Z
 system/dynamic-reconfiguration
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T164330Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030344Z
 system/embedded-fcode-interpreter
   0.5.11,5.11-0.175.2.1.0.5.2:20140801T183745Z -> 0.5.11,5.11-0.175.2.11.0.3.2:20150526T144659Z
 system/fault-management
   0.5.11,5.11-0.175.2.5.0.2.2:20141114T212020Z -> 0.5.11,5.11-0.175.2.14.0.1.2:20150806T214333Z
 system/fault-management/asr-notify
   0.5.11,5.11-0.175.2.5.0.2.2:20141114T212017Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030356Z
 system/fault-management/fm-snmp-mib
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185138Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030357Z
 system/file-system/autofs
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185204Z -> 0.5.11,5.11-0.175.2.10.0.1.2:20150406T224459Z
 system/file-system/hsfs
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185207Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030437Z
 system/file-system/nfs
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T164337Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T175949Z
 system/file-system/pcfs
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185218Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030451Z
 system/file-system/smb
   0.5.11,5.11-0.175.2.1.0.5.2:20140801T183748Z -> 0.5.11,5.11-0.175.2.12.0.4.2:20150626T204801Z
 system/file-system/ufs
   0.5.11,5.11-0.175.2.5.0.4.2:20141201T211014Z -> 0.5.11,5.11-0.175.2.13.0.4.2:20150724T225518Z
 system/file-system/uvfs
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185240Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030513Z
 system/file-system/zfs
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T164347Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T175956Z
 system/firmware-utilities
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185258Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030535Z
 system/hal
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185304Z -> 0.5.11,5.11-0.175.2.10.0.1.2:20150406T224536Z
 system/install
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185350Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030644Z
 system/install/auto-install/auto-install-common
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185337Z -> 0.5.11,5.11-0.175.2.13.0.2.2:20150710T213149Z
 system/install/configuration
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185342Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030633Z
 system/install/locale
   0.5.11,5.11-0.175.2.0.0.42.2:20140623T130840Z -> 0.5.11,5.11-0.175.2.8.0.1.3:20150207T032233Z
 system/io/fc/fc-port
   0.5.11,5.11-0.175.2.1.0.3.2:20140722T154523Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153346Z
 system/io/fc/fc-san-management
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185358Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030648Z
 system/io/fc/fc-scsi
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185400Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T202028Z
 system/io/fc/ip-over-fc
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185401Z -> 0.5.11,5.11-0.175.2.13.0.2.2:20150710T213154Z
 system/io/ieee-1394
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185403Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T202030Z
 system/io/infiniband
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T155226Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T180022Z
 system/io/infiniband/ethernet-over-ib
   0.5.11,5.11-0.175.2.5.0.3.2:20141124T151126Z -> 0.5.11,5.11-0.175.2.11.0.2.2:20150515T221131Z
 system/io/infiniband/ib-device-mgt-agent
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185407Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030653Z
 system/io/infiniband/ib-sockets-direct
   0.5.11,5.11-0.175.2.2.0.4.2:20140829T201249Z -> 0.5.11,5.11-0.175.2.13.0.3.2:20150720T153348Z
 system/io/infiniband/ip-over-ib
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185410Z -> 0.5.11,5.11-0.175.2.11.0.3.2:20150526T144730Z
 system/io/infiniband/open-fabrics
   0.5.11,5.11-0.175.2.5.0.4.2:20141201T211040Z -> 0.5.11,5.11-0.175.2.11.0.4.2:20150601T150613Z
 system/io/infiniband/reliable-datagram-sockets
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185417Z -> 0.5.11,5.11-0.175.2.8.0.3.2:20150221T002837Z
 system/io/infiniband/reliable-datagram-sockets-v3
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T155223Z -> 0.5.11,5.11-0.175.2.13.0.1.2:20150706T181203Z
 system/io/infiniband/rpc-over-rdma
   0.5.11,5.11-0.175.2.2.0.3.2:20140826T020625Z -> 0.5.11,5.11-0.175.2.8.0.3.2:20150221T002839Z
 system/io/infiniband/udapl
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185421Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030709Z
 system/io/usb
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T155230Z -> 0.5.11,5.11-0.175.2.12.0.2.2:20150615T141615Z
 system/kernel
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T164648Z -> 0.5.11,5.11-0.175.2.14.0.4.2:20150831T155255Z
 system/kernel/cpu/sun4v
   0.5.11,5.11-0.175.2.5.0.3.2:20141124T151127Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T180027Z
 system/kernel/io-performance-counters
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185449Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T030738Z
 system/kernel/platform
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T164546Z -> 0.5.11,5.11-0.175.2.15.0.4.2:20150923T160332Z
 system/kernel/power
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185534Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T202141Z
 system/kernel/security/gss
   0.5.11,5.11-0.175.2.5.0.1.2:20141110T173140Z -> 0.5.11,5.11-0.175.2.9.0.2.2:20150316T172855Z
 system/kernel/suspend-resume
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T155325Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T202143Z
 system/ldoms
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224801Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T180215Z
 system/ldoms/ldomsmanager
   3.1.1.2.2,5.11-0.175.2.5.0.2.0:20141114T212701Z -> 3.2.0.1.3,5.11-0.175.2.11.0.3.0:20150526T144348Z
 system/library
   0.5.11,5.11-0.175.2.5.0.3.2:20141124T151339Z -> 0.5.11,5.11-0.175.2.15.0.3.2:20150916T192021Z
 system/library/boot-management
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185700Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031027Z
 system/library/c++-runtime
   0.5.11,5.11-0.175.2.4.0.1.0:20141006T154627Z -> 0.5.11,5.11-0.175.2.13.0.2.0:20150710T212921Z
 system/library/freetype-2
   2.4.11,5.11-0.175.2.0.0.42.1406:20140623T215415Z -> 2.5.5,5.11-0.175.2.10.0.3.1434:20150417T202826Z
 system/library/hmp-libs
   2.2.8,5.11-0.175.2.2.0.4.0:20140829T201640Z -> 2.3.3.0,5.11-0.175.2.14.0.2.0:20150813T225349Z
 system/library/install
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185703Z -> 0.5.11,5.11-0.175.2.9.0.4.2:20150330T212923Z
 system/library/install/libinstzones
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185702Z -> 0.5.11,5.11-0.175.2.10.0.5.2:20150506T003618Z
 system/library/math
   0.5.11,5.11-0.175.2.5.0.2.0:20141114T212724Z -> 0.5.11,5.11-0.175.2.10.0.1.0:20150406T225802Z
 system/library/platform
   0.5.11,5.11-0.175.2.1.0.4.2:20140728T195223Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173423Z
 system/library/policykit
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185712Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031040Z
 system/library/processor
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185713Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031042Z
 system/library/storage/libdiskmgt
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185731Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173426Z
 system/library/storage/libfcoe
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185733Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031051Z
 system/library/storage/snia-hbaapi
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185736Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031052Z
 system/library/storage/snia-ima
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185740Z -> 0.5.11,5.11-0.175.2.8.0.2.2:20150214T030750Z
 system/library/storage/snia-mpapi
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185742Z -> 0.5.11,5.11-0.175.2.9.0.4.2:20150330T212935Z
 system/library/storage/suri
   0.5.11,5.11-0.175.2.1.0.3.2:20140722T154742Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031101Z
 system/library/storage/t11-sm-hba
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185747Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031103Z
 system/linker
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T185945Z -> 0.5.11,5.11-0.175.2.8.0.2.2:20150214T031021Z
 system/locale
   0.5.11,5.11-0.175.2.0.0.42.2:20140623T131828Z -> 0.5.11,5.11-0.175.2.12.0.3.2:20150622T162623Z
 system/management/fwupdate
   2.2.8,5.11-0.175.2.2.0.4.0:20140829T201741Z -> 2.3.3.0,5.11-0.175.2.14.0.2.0:20150813T225439Z
 system/management/fwupdate/emulex
   6.3.12.2,5.11-0.175.2.2.0.4.0:20140829T201721Z -> 6.3.12.2,5.11-0.175.2.14.0.2.0:20150813T225407Z
 system/management/fwupdate/qlogic
   1.7.3,5.11-0.175.2.2.0.4.0:20140829T201732Z -> 1.7.4,5.11-0.175.2.14.0.2.0:20150813T225422Z
 system/management/hmp-snmp
   2.2.8,5.11-0.175.2.2.0.4.0:20140829T201750Z -> 2.3.3.0,5.11-0.175.2.14.0.2.0:20150813T225443Z
 system/management/hwmgmtcli
   2.2.8,5.11-0.175.2.2.0.4.0:20140829T201753Z -> 2.3.3.0,5.11-0.175.2.14.0.2.0:20150813T225445Z
 system/management/hwmgmtd
   2.2.8,5.11-0.175.2.2.0.4.0:20140829T201755Z -> 2.3.3.0,5.11-0.175.2.14.0.2.0:20150813T225447Z
 system/management/ilomconfig
   5.11,5.11-0.175.2.2.0.4.0:20140829T201758Z -> 5.11,5.11-0.175.2.14.0.2.0:20150813T225451Z
 system/management/ipmitool
   1.8.12,5.11-0.175.2.2.0.4.0:20140829T201802Z -> 1.8.12,5.11-0.175.2.14.0.2.0:20150813T225453Z
 system/management/ocm
   12.0.0.0.0,5.11-0.175.2.0.0.39.0:20140512T125222Z -> 12.1.0.0.0,5.11-0.175.2.12.0.2.0:20150615T141350Z
 system/management/rad
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190031Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031454Z
 system/management/rad/client/rad-c
   0.5.11,5.11-0.175.2.4.0.5.2:20141030T213514Z -> 0.5.11,5.11-0.175.2.10.0.4.2:20150423T234447Z
 system/management/rad/client/rad-java
   0.5.11,5.11-0.175.2.4.0.5.2:20141030T213522Z -> 0.5.11,5.11-0.175.2.10.0.4.2:20150423T234454Z
 system/management/rad/client/rad-python
   0.5.11,5.11-0.175.2.4.0.5.2:20141030T213524Z -> 0.5.11,5.11-0.175.2.10.0.4.2:20150423T234455Z
 system/management/rad/module/rad-dlmgr
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T202912Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031440Z
 system/management/rad/module/rad-files
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190019Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031443Z
 system/management/rad/module/rad-kstat
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190020Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031444Z
 system/management/rad/module/rad-network
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190021Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031445Z
 system/management/rad/module/rad-panels
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190022Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031446Z
 system/management/rad/module/rad-smf
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190024Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031447Z
 system/management/rad/module/rad-time
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190025Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031448Z
 system/management/rad/module/rad-usermgr
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190026Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031449Z
 system/management/rad/module/rad-zonemgr
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190028Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T180354Z
 system/management/raidconfig
   2.2.8,5.11-0.175.2.2.0.4.0:20140829T201804Z -> 2.3.3.0,5.11-0.175.2.14.0.2.0:20150813T225455Z
 system/management/snmp/net-snmp
   5.4.1,5.11-0.175.2.5.0.1.0:20141110T173753Z -> 5.4.1,5.11-0.175.2.13.0.4.0:20150724T230217Z
 system/manual/locale
   0.5.11,5.11-0.175.2.0.0.42.2:20140623T133506Z -> 0.5.11,5.11-0.175.2.8.0.1.3:20150207T034109Z
 system/network
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224830Z -> 0.5.11,5.11-0.175.2.13.0.5.2:20150731T191239Z
 system/network/bpf
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224812Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031459Z
 system/network/ike
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224814Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T180356Z
 system/network/nis
   0.5.11,5.11-0.175.2.6.0.1.2:20141208T172419Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031503Z
 system/network/ppp
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190104Z -> 0.5.11,5.11-0.175.2.10.0.1.2:20150406T225647Z
 system/network/routing
   0.5.11,5.11-0.175.2.4.0.1.2:20141006T154556Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031512Z
 system/picl
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190118Z -> 0.5.11,5.11-0.175.2.9.0.3.2:20150321T014743Z
 system/resource-mgmt/resource-caps
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190123Z -> 0.5.11,5.11-0.175.2.10.0.2.2:20150413T213133Z
 system/resource-mgmt/resource-pools
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190125Z -> 0.5.11,5.11-0.175.2.13.0.1.2:20150706T181404Z
 system/storage/fc-utilities
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190133Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031540Z
 system/storage/fcoe
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T202939Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T202509Z
 system/storage/iscsi/iscsi-initiator
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T164847Z -> 0.5.11,5.11-0.175.2.8.0.3.2:20150221T003738Z
 system/storage/iscsi/iscsi-iser
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190141Z -> 0.5.11,5.11-0.175.2.12.0.1.2:20150605T173604Z
 system/storage/media-volume-manager
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190147Z -> 0.5.11,5.11-0.175.2.10.0.3.2:20150417T202510Z
 system/storage/raid-utilities
   0.5.11,5.11-0.175.2.4.0.4.2:20141027T155720Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031552Z
 system/storage/removable-media
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190154Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031553Z
 system/storage/sas-utilities
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190156Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031555Z
 system/system-events
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190206Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031608Z
 system/xopen/xcu4
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T202940Z -> 0.5.11,5.11-0.175.2.13.0.1.2:20150706T181407Z
 system/xopen/xcu6
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T202944Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031621Z
 system/zones
   0.5.11,5.11-0.175.2.6.0.3.2:20141222T164857Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T180422Z
 system/zones/brand/brand-solaris
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T203011Z -> 0.5.11,5.11-0.175.2.10.0.5.2:20150506T003622Z
 system/zones/brand/brand-solaris-kz
   0.5.11,5.11-0.175.2.6.0.2.2:20141212T224850Z -> 0.5.11,5.11-0.175.2.14.0.3.2:20150821T180406Z
 system/zones/brand/brand-solaris10
   0.5.11,5.11-0.175.2.4.0.2.2:20141010T203012Z -> 0.5.11,5.11-0.175.2.12.0.3.2:20150622T164915Z
 text/doctools
   0.5.11,5.11-0.175.2.0.0.42.2:20140624T190250Z -> 0.5.11,5.11-0.175.2.8.0.1.2:20150207T031701Z
 text/gnu-patch
   2.7.1,5.11-0.175.2.4.0.5.0:20141030T213844Z -> 2.7.5,5.11-0.175.2.13.0.4.0:20150724T230225Z
 web/curl
   7.21.2,5.11-0.175.2.5.0.4.0:20141201T211320Z -> 7.40.0,5.11-0.175.2.14.0.3.0:20150821T180437Z
 x11/library/libxfont
   1.4.7,5.11-0.175.2.0.0.42.1406:20140623T215556Z -> 1.4.7,5.11-0.175.2.9.0.4.1428:20150330T222043Z
 x11/server/xorg
   1.14.5,5.11-0.175.2.6.0.3.1423:20141222T165137Z -> 1.14.5,5.11-0.175.2.11.0.2.1436:20150515T221820Z
 x11/server/xvnc
   1.1.0,5.11-0.175.2.6.0.3.1423:20141222T165151Z -> 1.1.0,5.11-0.175.2.11.0.2.1436:20150515T221831Z
 runtime/java/jre-7
   1.7.0.85.33,5.11:20150805T160501Z
Editable files to change:
 Install:
   etc/sane.d/abaton.conf
   etc/sane.d/apple.conf
   etc/sane.d/artec.conf
   etc/sane.d/artec_eplus48u.conf
   etc/sane.d/avision.conf
   etc/sane.d/bh.conf
   etc/sane.d/canon.conf
   etc/sane.d/canon630u.conf
   etc/sane.d/cardscan.conf
   etc/sane.d/coolscan.conf
   etc/sane.d/coolscan2.conf
   etc/sane.d/dc25.conf
   etc/sane.d/dell1600n_net.conf
   etc/sane.d/dll.conf
   etc/sane.d/dmc.conf
   etc/sane.d/epjitsu.conf
   etc/sane.d/epson.conf
   etc/sane.d/fujitsu.conf
   etc/sane.d/genesys.conf
   etc/sane.d/gt68xx.conf
   etc/sane.d/hp.conf
   etc/sane.d/hp3900.conf
   etc/sane.d/hp5400.conf
   etc/sane.d/hs2p.conf
   etc/sane.d/ibm.conf
   etc/sane.d/leo.conf
   etc/sane.d/lexmark.conf
   etc/sane.d/ma1509.conf
   etc/sane.d/matsushita.conf
   etc/sane.d/microtek.conf
   etc/sane.d/microtek2.conf
   etc/sane.d/mustek.conf
   etc/sane.d/mustek_usb.conf
   etc/sane.d/nec.conf
   etc/sane.d/net.conf
   etc/sane.d/pie.conf
   etc/sane.d/plustek.conf
   etc/sane.d/plustek_pp.conf
   etc/sane.d/ricoh.conf
   etc/sane.d/sceptre.conf
   etc/sane.d/sharp.conf
   etc/sane.d/sm3840.conf
   etc/sane.d/snapscan.conf
   etc/sane.d/sp15c.conf
   etc/sane.d/st400.conf
   etc/sane.d/teco1.conf
   etc/sane.d/teco2.conf
   etc/sane.d/teco3.conf
   etc/sane.d/test.conf
   etc/sane.d/u12.conf
   etc/sane.d/umax.conf
   etc/sane.d/umax1220u.conf
   etc/sane.d/umax_pp.conf
   var/log/ssm/event.log
   var/openldap/openldap-data/DB_CONFIG
 Update:
   etc/acct/holidays
   etc/driver/drv/lsc.conf
   etc/mail/sendmail.cf
   etc/mail/submit.cf
   etc/openldap/ldap.conf
   etc/openldap/slapd.conf
   etc/security/priv_names
   var/log/ssm/fwupdate.log
   var/log/ssm/hwmgmtcli.log
   var/log/ssm/hwmgmtd.log
   var/log/ssm/raidconfig.log
   var/ocm/ccr/config/ccr.properties
   var/ocm/ccr/config/collector.properties
   var/ocm/ccr/config/default/collector_config.inventory
   var/ocm/ccr/config/default/sched.properties
   var/ocm/ccr/config/default/targets.xml
   var/ocm/ccr/config/default/uplinkreg.bin
   var/ocm/ccr/config/emCCRenv
   var/ocm/ccr/config/sched.properties
   var/ocm/ccr/log/collector.log
   var/ocm/ccr/log/sched.log
   var/ocm/ccr/log/upgrade.log
   var/ocm/ccr/state/sched.state
   var/ocm/ccr/state/semaphore.op
   var/ocm/ccr/state/semaphore.update
10. Perform the update ( -v will give you a verbose output)
bash-4.1# pkg update --be-name s11.2-sru15
           Packages to remove:   2
          Packages to install:  36
           Packages to update: 264
           Packages to change:   1
          Mediators to change:   1
      Create boot environment: Yes
Create backup boot environment:  No
DOWNLOAD                                PKGS         FILES    XFER (MB)   SPEED
Completed                            303/303   18491/18491  515.6/515.6  5.0M/s
PHASE                                          ITEMS
Removing old actions                       1799/1799
Installing new actions                   10158/10158
Updating modified actions                16535/16535
Updating package state database                 Done
Updating package cache                       266/266
Updating image state                            Done
Creating fast lookup database                   Done
Updating package cache                           1/1
A clone of solaris-1 exists and has been updated and activated.
On the next boot the Boot Environment s11.2-sru15 will be
mounted on '/'.  Reboot when ready to switch to this updated BE.
Updating package cache                           1/1
---------------------------------------------------------------------------
NOTE: Please review release notes posted at:
https://support.oracle.com/rs?type=doc&id=1672221.1
---------------------------------------------------------------------------
11. Verify the new BE is created and activated
bash-4.1# beadm list
BE               Active Mountpoint Space  Policy Created
--               ------ ---------- -----  ------ -------
install          -      -          62.0K  static 2015-04-09 10:23
pre_11_2         -      -          3.43M  static 2015-04-09 11:42
pre_vxvm610      -      -          258.0K static 2015-04-09 10:35
solaris          -      -          24.05M static 2015-04-09 09:54
solaris-1        N      /          47.80M static 2015-04-09 11:54  
s11.2-sru15      R      -          20.09G static 2016-03-06 16:47  <<<----
solaris-backup-1 -      -          3.47M  static 2015-04-09 11:27
12. Follow the reboot instruction of the Server

Solaris 10 LDOM Kernel Patching using Live Upgrade.

Solaris 10 LDOM Kernel Patching using Live Upgrade.


Here is the procedure to upgrade the Kernel patches in Solaris 10 with ZFS file-system using Live upgrade method


1. Check the the current Kernel version and Confirm whether upgrade is required or not

 root@sol10-ldom:/root:# uname -a
 SunOS sol10-ldom 5.10 Generic_147147-26 sun4v sparc sun4v
  root@sol10-ldom:/root:#

2. Check the existing Boot Environments

 root@sol10-ldom:/root:# lustatus
 ERROR: No boot environments are configured on this system
 ERROR: cannot determine list of all boot environment names

3. Ensure the rpool status is ONLINE

 root@sol10-ldom:/root:# zpool list
 NAME     SIZE  ALLOC   FREE  CAP  HEALTH  ALTROOT
 oracle  31.8G  17.5G  14.3G  55%  ONLINE  -
 rpool   95.8G  66.5G  29.2G  69%  ONLINE  -
4. Ensure the Solaris Release
(If you are upgrading to a new Solaris release please install live upgrade package from new release)
root@sol10-ldom:/root:# cat /etc/release
                   Oracle Solaris 10 1/13 s10s_u11wos_24a SPARC
  Copyright (c) 1983, 2013, Oracle and/or its affiliates. All rights reserved.
                            Assembled 17 January 2013
5. Check the live upgrade patch version ( It is recommended to install the latest live-upgrade patches)
 root@sol10-ldom:/root:# showrev -p |grep 121430

 Patch: 121430-85 Obsoletes: 121435-04, 121437-02 Requires:  Incompatibles: Packages: SUNWlucfg, SUNWluu, SUNWlur                                                                                 
 Patch: 121428-15 Obsoletes:  Requires: 120235-01, 121430-16 Incompatibles: Packages: SUNWluzone                                                                         
New Version can be found in following link
6. Ensure the live upgrade packages are installed properly
 root@sol10-ldom:/root:# pkginfo -l SUNWlucfg
   PKGINST:  SUNWlucfg
      NAME:  Live Upgrade Configuration
  CATEGORY:  application
      ARCH:  sparc
   VERSION:  11.10,REV=2007.03.09.13.13
   BASEDIR:  /
    VENDOR:  Oracle Corporation
      DESC:  Live Upgrade Configuration
    PSTAMP:  on10-adms-patch20110330171403
  INSTDATE:  Mar 25 2015 17:27
   HOTLINE:  Please contact your local service provider
    STATUS:  completely installed
     FILES:        5 installed pathnames
                   3 shared pathnames
                   3 directories
                  35 blocks used (approx)

 root@sol10-ldom:/root:# pkginfo -l SUNWluu
   PKGINST:  SUNWluu
      NAME:  Live Upgrade (usr)
  CATEGORY:  application
      ARCH:  sparc
   VERSION:  11.10,REV=2005.01.10.00.03
   BASEDIR:  /
    VENDOR:  Oracle Corporation
      DESC:  Live Upgrade (usr)
    PSTAMP:  on28-patch20120604223443
  INSTDATE:  Mar 25 2015 17:29
   HOTLINE:  Please contact your local service provider
    STATUS:  completely installed
     FILES:      161 installed pathnames
                   7 shared pathnames
                  11 directories
                  41 executables
                2552 blocks used (approx)

 root@sol10-ldom:/root:# pkginfo -l SUNWlur
   PKGINST:  SUNWlur
      NAME:  Live Upgrade (root)
  CATEGORY:  application
      ARCH:  sparc
   VERSION:  11.10,REV=2005.01.10.00.03
   BASEDIR:  /
    VENDOR:  Oracle Corporation
      DESC:  Live Upgrade (root)
    PSTAMP:  on28-patch20120604223459
  INSTDATE:  Mar 25 2015 17:29
   HOTLINE:  Please contact your local service provider
    STATUS:  completely installed
     FILES:       40 installed pathnames
                  11 shared pathnames
                   4 linked files
                  15 directories
                  14 executables
                2275 blocks used (approx)
7. Create a Current BE and New BE and specify the name appropriately
root@sol10-ldom:/root:# lucreate -c sol10-build -n sol10_20151108 -p rpool
Analyzing system configuration.
No name for current boot environment.
Current boot environment is named <sol10-build>.
Creating initial configuration for primary boot environment <sol10-build>.
INFORMATION: No BEs are configured on this system.
The device </dev/dsk/c0d0s0> is not a root device for any boot environment; cannot get BE ID.
PBE configuration successful: PBE name <sol10-build> PBE Boot Device </dev/dsk/c0d0s0>.
Updating boot environment description database on all BEs.
Updating system configuration files.
Creating configuration for boot environment <sol10_20151108>.
Source boot environment is <sol10-build>.
Creating file systems on boot environment <sol10_20151108>.
Populating file systems on boot environment <sol10_20151108>.
Analyzing zones.
Duplicating ZFS datasets from PBE to ABE.
Creating snapshot for <rpool/ROOT/s10s_u11wos_24a> on <rpool/ROOT/s10s_u11wos_24a@sol10_20151108>.
Creating clone for <rpool/ROOT/s10s_u11wos_24a@sol10_20151108> on <rpool/ROOT/sol10_20151108>.
Mounting ABE <sol10_20151108>.
Generating file list.
Finalizing ABE.
Fixing zonepaths in ABE.
Unmounting ABE <sol10_20151108>.
Fixing properties on ZFS datasets in ABE.
Reverting state of zones in PBE <sol10-build>.
Making boot environment <sol10_20151108> bootable.
Population of boot environment <sol10_20151108> successful.
Creation of boot environment <sol10_20151108> successful.
8. Check both BE's are created
root@sol10-ldom:/root:# lustatus
Boot Environment           Is       Active Active    Can    Copy
Name                       Complete Now    On Reboot Delete Status
-------------------------- -------- ------ --------- ------ ----------
sol10-build                yes      yes    yes       no     -
sol10-20151108             yes      no     no       yes     -
9. Check the BE status of Both Boot Environments
root@sol10-ldom:/root:# lufslist -n sol10-build
               boot environment name: sol10-build
               This boot environment is currently active.
               This boot environment will be active on next system boot.

Filesystem              fstype    device size Mounted on          Mount Options
----------------------- -------- ------------ ------------------- --------------
/dev/zvol/dsk/rpool/swap swap      34359738368 -                   -
rpool/ROOT/s10s_u11wos_24a zfs       28473121280 /                   -
oracle/sabre            zfs             31744 /app/sabre          -
rpool/export            zfs             88064 /export             -
rpool/export/home       zfs             55296 /export/home        -
oracle                  zfs       16812273152 /opt/oracle         -
oracle/pkgs             zfs             31744 /pkgs               -
rpool                   zfs       81643988480 /rpool         

root@sol10-ldom:/root:# lufslist -n sol10_20151108
               boot environment name: sol10_20151108

Filesystem              fstype    device size Mounted on          Mount Options
----------------------- -------- ------------ ------------------- --------------
/dev/zvol/dsk/rpool/swap swap      34359738368 -                   -
rpool/ROOT/sol10_20151108 zfs            287232 /                   -
oracle/sabre            zfs             31744 /app/sabre          -
rpool/export            zfs             88064 /export             -
rpool/export/home       zfs             55296 /export/home        -
oracle                  zfs       16812273152 /opt/oracle         -
oracle/pkgs             zfs             31744 /pkgs               -
rpool                   zfs       81644261376 /rpool              -
10. Now Apply the per-request patch on the current BE
root@sol10-ldom:/root:# cd /nfs-share/sol10-KJP/10_Recommended_20151108
root@sol10-ldom:/root:# ./installcluster --apply-prereq --s10patchset
Setup .
Recommended OS Patchset Solaris 10 SPARC (2015.11.12)

Application of patches started : 2016.02.25 19:16:34

Applying 120900-04 ( 1 of 10) ... skipped
Applying 121133-02 ( 2 of 10) ... skipped
Applying 119254-92 ( 3 of 10) ... success
Applying 119317-01 ( 4 of 10) ... skipped
Applying 121296-01 ( 5 of 10) ... skipped
Applying 138215-02 ( 6 of 10) ... success
Applying 148336-02 ( 7 of 10) ... success
Applying 146054-07 ( 8 of 10) ... skipped
Applying 142251-02 ( 9 of 10) ... skipped
success

Application of patches finished : 2016.02.25 19:17:13

Following patches were applied :
 119254-92     138215-02     148336-02     125555-16

Following patches were skipped :
 Patches already applied
 120900-04     119317-01     121296-01     146054-07     142251-02
 121133-02
Installation of prerequisite patches complete.

Install log files written :
  /var/sadm/install_data/s10s_rec_patchset_short_2016.02.25_19.16.34.log
  /var/sadm/install_data/s10s_rec_patchset_verbose_2016.02.25_19.16.34.log
11. Now install the 10_Recommended patches on the inactive boot environment using -B option
root@sol10-ldom:/root:# ./installcluster -B sol10_20151108 --s10patchset

Setup ....
Recommended OS Patchset Solaris 10 SPARC (2015.11.12)
Application of patches started : 2016.02.25 19:19:22

Applying 120900-04 (  1 of 392) ... skipped
Applying 121133-02 (  2 of 392) ... skipped
Applying 119254-92 (  3 of 392) ... success
Applying 119317-01 (  4 of 392) ... skipped
Applying 121296-01 (  5 of 392) ... skipped
Applying 138215-02 (  6 of 392) ... success
Applying 148336-02 (  7 of 392) ... success
Applying 146054-07 (  8 of 392) ... skipped
Applying 142251-02 (  9 of 392) ... skipped
Applying 125555-16 ( 10 of 392) ... success
Applying 118367-04 ( 11 of 392) ... skipped
Applying 118666-86 ( 12 of 392) ... success
...
...
...
Applying 151561-01 (384 of 392) ... success
Applying 151615-01 (385 of 392) ... success
Applying 151696-01 (386 of 392) ... success
Applying 151717-01 (387 of 392) ... success
Applying 151719-01 (388 of 392) ... skipped
Applying 151755-01 (389 of 392) ... success
Applying 152076-05 (390 of 392) ... success
Applying 152077-05 (391 of 392) ... success
Applying 152083-01 (392 of 392) ... success

Application of patches finished : 2016.02.25 20:33:25

Following patches were applied :
 119254-92     124939-05     147673-10     149112-01     150383-10
 138215-02     125215-05     147793-17     150400-30     150534-01
 148336-02     125719-56     147797-04     149173-04     150535-01
 125555-16     125725-03     147992-06     149175-09     150537-01
 118666-86     125731-12     148049-04     149279-04     150539-01
 ....<snip>
 121095-04     145080-15     148888-05     150180-02     151755-01
 122911-35     150510-03     149067-01     150307-01     152076-05
 123893-77     146288-03     149071-01     150310-02     152077-05
 123938-04     146582-05     149075-01     150312-06     152083-01

Following patches were skipped :
 Patches already applied
 120900-04     140796-01     141016-01     138766-01     145120-01
 121133-02     120011-14     139555-08     138852-01     145648-03
 119317-01     139520-02     142292-01     139289-02     147442-01
 121296-01     119903-02     141444-09     139615-01     147147-26
 146054-07     119963-24     142911-01     139962-02     147143-17
 142251-02     119966-01     142933-05     139980-01     146334-01
 118367-04     119986-03     142909-17     139986-01     146673-01
 118707-05     120101-01     144526-02     140912-01     146679-01
 ....<Snip>
 119313-42     124397-02     137115-01     143739-01     148625-01
 124188-03     124997-01     137147-07     144047-01     148870-01
 120099-08     125075-01     137282-01     144106-01     148948-01
 119546-08     125505-01     137871-02     144188-02     148975-01
 119648-03     125533-17     138096-02     144327-02     149108-01
 122640-05     125891-01     138181-01     147002-01     149149-01
 126897-02     126540-02     138245-01     144909-03     149163-01
 127755-01     127127-11     138647-01     145023-01     149165-01
 125503-02     138866-03     138649-01     147217-02     149483-01
 125547-02     137137-09
 Patches obsoleted by one or more patches already applied
 118712-23     118731-01     120753-09     139099-04     144455-01
 118718-06     124204-04     121308-20     139620-01     144492-01
 119117-52     122660-10     122470-03     140455-01     144569-01
 119246-39     119764-07     124171-07     141532-04     144911-02
 124628-10     119906-18     123630-03     141586-01     145096-03
 119252-29     119955-05     124457-02     142049-01     145929-05
 119278-38     120460-17     124630-42     142234-01     146954-03
 119315-19     119368-04     125279-05     143733-01     147194-03
 120199-15     120286-03     126365-16     143954-04     147378-01
 119534-29     120292-02     138247-01     144112-02     148135-01
 119538-19     120348-03     138361-01     144325-01     148165-02
 120272-31     120410-33     138854-01
 Patches not applicable to packages on the system
 118705-02     120414-27     121211-02     137004-09     143651-01
 118706-01     120811-09     121946-01     137090-02     143727-04
 118711-03     120812-32     122031-01     138195-04     144996-02
 121181-05     120815-01     122472-07     138824-12     145200-13
 119309-03     120849-04     123005-07     139291-02     147692-91
 119548-14     120928-32     123301-01     142244-02     147693-91
 120195-02     121104-11     125332-24     143317-03     151009-65
 120256-01     121136-02     125670-04     143527-01     151719-01
 120412-11
 Patches canceled due to prepatch termination
 150551-03

Installation of patch set to alternate boot environment complete.

Please remember to activate boot environment sol10_20151108 with luactivate(1M)
before rebooting.

Install log files written :
  /.alt.sol10_20151108/var/sadm/install_data/s10s_rec_patchset_short_2016.02.25_19.19.22.log
  /.alt.sol10_20151108/var/sadm/install_data/s10s_rec_patchset_verbose_2016.02.25_19.19.22.log
12. Activate the patched BE
 root@sol10-ldom:/root:# luactivate sol10_20151108

 A Live Upgrade Sync operation will be performed on startup of boot environment <sol10_20151108>.
 **********************************************************************
 The target boot environment has been activated. It will be used when you
 reboot. NOTE: You MUST NOT USE the reboot, halt, or uadmin commands. You
 MUST USE either the init or the shutdown command when you reboot. If you
 do not use either init or shutdown, the system will not boot using the
 target BE.
 **********************************************************************
 In case of a failure while booting to the target BE, the following process
 needs to be followed to fallback to the currently working boot environment:

 1. Enter the PROM monitor (ok prompt).

 2. Boot the machine to Single User mode using a different boot device
 (like the Solaris Install CD or Network). Examples:
     At the PROM monitor (ok prompt):
     For boot to Solaris CD:  boot cdrom -s
     For boot to network:     boot net -s

 3. Mount the Current boot environment root slice to some directory (like
 /mnt). You can use the following commands in sequence to mount the BE:
     zpool import rpool
     zfs inherit -r mountpoint rpool/ROOT/s10s_u11wos_24a
     zfs set mountpoint=<mountpointName> rpool/ROOT/s10s_u11wos_24a
     zfs mount rpool/ROOT/s10s_u11wos_24a

 4. Run <luactivate> utility with out any arguments from the Parent boot
 environment root slice, as shown below:
     <mountpointName>/sbin/luactivate

 5. luactivate, activates the previous working boot environment and
 indicates the result.

 6. umount /mnt

 7. zfs set mountpoint=/ rpool/ROOT/s10s_u11wos_24a

 8. Exit Single User mode and reboot the machine.
 **********************************************************************
 Modifying boot archive service
 Activation of boot environment <sol10_20151108> successful.

 root@sol10-ldom:/root:# lustatus
 Boot Environment           Is       Active Active    Can    Copy
 Name                       Complete Now    On Reboot Delete Status
 -------------------------- -------- ------ --------- ------ ----------
 sol10-build                yes      yes    no        no      -
 sol10-20151108             yes      no     yes       yes     -
13. Reboot the server
Use init 6 or shutdown -y -g0 -i6 (Follow the reboot instructions)